• XEN DEVELOPMENT is a developer's resource for new developers wanting to build XenForo 2 add-ons. Experienced developers are also welcome to share their experienes and knowledge. This site is not affiliated with XenForo or a replacement for the official XenForo developer forums.

Author of Post is not showing in Xenforo Thread

Laron

New member
Lifetime License
(It looks like my bug wasn't carried across, so I'm posting this bug again)

WordPress version: Latest Version
XenForo version: Latest Version
XenWord version: 2018.06.14-NR

What WordPress theme are you using?

Newspaper

To the best of your abilities please describe the specific problem you are experiencing:

When posting a post in wordpress and selecting an author which is not me, in Xenforo the thread created is under my name, not the author I selected. As a workaround I have to change the author in xenforo using an addon every single time I post an post in wordpress. While this takes around 10-20 seconds, it's a bit of a hassle as it has to be done pretty much every time I post a post in wordpress which I do daily.
 

LPH

Flight Director
Staff member
I don't understand. Is each WordPress post a different author?

If I'm interpreting your post properly, all authors should be aligned between XenForo and WordPress. If you have that many authors then you'll want to go through the databases and align the user_id and IDs.

Some customers use this WordPress plugin.
 

Laron

New member
Lifetime License
LPH, I logged this bug about 3-4 weeks ago and you're telling me now you don't understand what the bug is? This is the second highest priority of those bugs I logged as this is a real pain to have to deal with every time I post.

This happened after I upgraded from Xenforo 1.5x to 2.x, and installed the required Xenword plugin that worked with Xenforo 2.x. All the versions I have tried since then still has this bug.

I have around 35 contributing authors. Only two of them have permission to post directly and use the portal, because it's a hassle for the others to learn how to log into the portal when they have to keep refreshing the page on the forum, as discussed on another thread on this forum when logging into wordpress. I get them to send me the content and I post it on their behalf.

Here is the process.

new post 1.jpg

I create a new post, or use the clone post feature (wordpress plugin), but the bug occurs with post ways of creating a post.

I fill out the usual information on the post, but what this bug relates to is this.

author.jpg

Because most of the time I'm posting other authors content, I rarely use my name as I don't write as often anymore. I click on my name in that image above and select the respective author of the article I've copied and pasted into the post.

I hit publish, and in Xenforo the thread that gets created with a brief excerpt advertising the new article (post) on the front page is not the author I selected above, it's me, no matter who I select. I then have to change the author of the xenforo thread manually to the author of the post, otherwise this confuses members of the forum as to who posted the article.

all authors should be aligned between XenForo and WordPress. If you have that many authors then you'll want to go through the databases and align the user_id and IDs.
This was done when I first installed Xenword years ago. Do I have to do this again? Is that your recommendation? As everything else has been working fine (with the exception of the bugs I logged). If they were not aligned, surely other issues would come up such as the author bio not matching the username. Also the users get added just fine when a new user is setup as a contributing author in wordpress from xenforo, as I have special groups set in Xenforo that align with the groups in wordpress as part of xenword.

Let me know if you need any other information.
 

LPH

Flight Director
Staff member
LPH, I logged this bug about 3-4 weeks ago and you're telling me now you don't understand what the bug is?
Each portion of XenWord is written in subsystems. When someone states there is a bug -- and their post discusses Authors then there are key pieces of information needed. However, as pointed out earlier to you, I need to verify whether you are actually discussing the Author subsystem or whether it is in fact in the Post.php file, which chooses the author.

Let's start over. I'm assuming the person's name is available in the pulldown from what you posted. I also need to know your WordPress settings for that pulldown. Are you using nicenames, first name, last name, etc? Knowing this option is vital because you must match the setting in the Thread Text to the one you want to be written to XenForo.

In other words, if you want the WordPress name to be written in the XenForo thread first post, then make sure that is the setting. If you want the XenForo author name then make sure that is the setting. I suspect this is actually the issue and it's not a bug but you having incorrect settings. Of course, I could be wrong. It's a guess based on your posts.

XenWord First Post Contains.png

You can always change settings in XenWord use the Blue Button Post Update and see how things are influenced.

Baring my above guess is incorrect, then please check the following:

The settings for the Author subsystem (screenshots are helpful).
The secondary user mapping
Double check the alignment of the user_id and IDs
Is the XenForo account actually in the WordPress database?

Sometimes it is a guess on my part to figure out where the person is interpreting settings and what they expect. My guess is you are actually referring to Thread Text and not Author system.
 

Laron

New member
Lifetime License
The settings for the Author subsystem (screenshots are helpful).
The secondary user mapping
Double check the alignment of the user_id and IDs
Is the XenForo account actually in the WordPress database?
nc.jpg

User mapping is turned off as I do it manually.

Double check the alignment of the user_id and IDs
Is the XenForo account actually in the WordPress database?
I will check the id's and get back to you.

What is the xenforo account name? Where do I look for it in WP DB?
 

LPH

Flight Director
Staff member
Make sure that the Nickname is filled in and saved in WordPress.
Gracie as Author.png

Here is an example of my creating a post and choosing Gracie as the Author.

Gracie as Nickname in XF.png

You see that "Gracie Nickname" is pulled from the Nickname (required).
 

Laron

New member
Lifetime License
Make sure that the Nickname is filled in and saved in WordPress.
I checked three of the regular authors and their Nickname is already set to their Xenforo username so I have made no changes there.

I'm going to check the database now to make sure the users are aligned.
 

Laron

New member
Lifetime License
I have confirmed the users are aligned (no changes made). I also checked the user meta for one of the users to make sure wpd3f19kj_capabilities was set correctly. (I use contributor and author, as there's a mix of permissions for posters)

So the issue is still here.
 

LPH

Flight Director
Staff member
In which case, I don't understand the issue. As shown in my earlier post, the option to choose the author is pulled during the creation of the WordPress post. If the option is for nicename, then the author's nickname found in WordPress database is used.

Please open a support ticket thread, provide all of the information in the XenWord Pro checklist. Next, please create a user in XenForo with super admin permissions so that I may log into /yourcommunity/admin.php. This user should be "LPH." You'll need to provide the password, too.

Doing this will allow me to check secondary user group settings. Next, I'll use the account to go to /wp-admin and check the XenWord Pro settings as well as look at a sample post of what you are trying to describe.

It's probably the easiest way rather than my guessing what is happening.

This is a place you should post the information:

https://www.xendevelopment.com/forums/xenword-support-ticket.20/
 

Laron

New member
Lifetime License
Sorry LPH, I can't give you that type of access as the users of my site have confidential information in Xenforo. I'm happy to provide screen shots of any settings you require to see.

Isn't this occurring for all your customers? I'm surprised no one else has logged this bug.

You said you don't understand the issue. I will try again to explain it.

I create a new post in wordpress, fill in all the required fields, change the author from me to the author of the post, hit submit. The post is posted in wordpress, and a copy is made as a new thread in xenforo, but the author is not the author I selected in WordPress, as shown in the thread on xenforo, it's me every single time. I have to then change the author in xenforo (using an addon I installed) to the correct author, as per what is set in wordpress.

Each author/contributor has their correct permissions set in both xenword and wordpress.

Next, I'll use the account to go to /wp-admin and check the XenWord Pro settings as well as look at a sample post of what you are trying to describe.
As I mentioned earlier, I setup accounts manually in terms of permissions once the user has visited from Xenforo. I don't have them automatically set as per the xenword options. Should I try turning this on and see if this helps?
 
Last edited:

Laron

New member
Lifetime License
So below is the author box, where I change the author from me to the correct author in wordpress.

author box.jpg

Yet in Xenforo, the automatically created thread author is always me, no matter who I pick on this list. This was working fine before I upgraded from xenforo 1.5x to 2.x, so something changed with the uprade and version of xenword that went with it.

The code for xenword that handles the post author in xenforo, linked to the field above in wordpress, is what would need to be looked at.

Note that the author mention in the thread in xenforo is correct however, and matches the author selected in wordpress, so this issue is only about the author of the thread.
 

Laron

New member
Lifetime License
As I mentioned earlier, I setup accounts manually in terms of permissions once the user has visited from Xenforo. I don't have them automatically set as per the xenword options. Should I try turning this on and see if this helps?
I have since tested this with user mapping turned on and this didn't resolve the issue. Feel free to privately message me as well for more information.
 

LPH

Flight Director
Staff member
Sorry LPH, I can't give you that type of access as the users of my site have confidential information in Xenforo. I'm happy to provide screen shots of any settings you require to see.
At this point, I really cannot help without access to being able to see how things are set. It's really just shooting in the dark and that is a waste of time. It's a huge burden to state something doesn't work and not let me verify.

The code for xenword that handles the post author in xenforo, linked to the field above in wordpress, is what would need to be looked at.
As shown above, this works. It links properly. It pulls properly. I can't say anything else because without access then I cannot tell what is happening on your site installation.

Let me explain. Someone stated redirections were a problem. I looked. It turned out their site_url was incorrect. In another case, someone stated they were locked out. It turned out their site_url was wrong and the .htaccess was built wrong, redirecting to http when they were using https. Another person stated they were locked out. It turned out the IDs and user_ids matched but not the usermeta tables. Another person stated caching didn't work and it turned out they never cleared the caching after installing XenWord. Another site said there were problems at it turned out to be CloudFlare was having issues that moment.

I could list example after example of people stating something doesn't work and it turns out to be a setting outside the realm of XenWord. There are just too many settings and options with WordPress to test everything. Therefore, without access -- this thread could go on for a long time of my suggestions for you to check this or that or another.

And this is important - if there is an issue then I want it resolved. This means at this point, I need access or we need to accept that we are just shooting in the dark. I'll happily keep going with suggestions but it's all a shot in the dark.

Next step for me
With that said, I'm going to look at the fact you aren't using mapping. You cannot test user mapping by simply turning it on and going on with life. The user must log in to XenForo, then browse to WordPress to have roles changed. I'll look at the code for mapping turned off.

Next step for you
The most important thing for you to know is that the mapping code is always based on the XenForo user_id and so you'll want to make sure you aren't trying to use email as a login option. Please check that setting and let me know.
 

Laron

New member
Lifetime License
I've never had this setting turned on.

Image15.jpg

At this point, I really cannot help without access to being able to see how things are set.
I understand and this is fair. I just take the privacy of those I look after seriously. If it was a more serious issue I would consider your request.

If you want to throw out a list of things I can personally check, feel free to do so as I used to work in a senior I.T. support position and I was the main troubleshooter, so delving into problems was my specialty.

Perhaps I will just continue on with this bug and just accept it won't be resolved.

I have seriously been considering dropping xenword and changing the way the site functions, as it's been very time consuming dealing with all the bugs that come up with it, whether the issue was unrelated to xenword, but causing a bug, or if it was a xenword issue — I'm just getting tired of this and I need everything to run more smoothly. (I've been thinking about just using xenforo and installing a portal and SEO addon).

Thanks for all your help. I will leave this with you. Whatever you decide is fine.
 
Top